В Android исправлены 6 уязвимостей, позволяющих удаленно выполнить код

Разработчик ядра Linux Скотти Бауэр (Scotty Bauer) обнаружил новый способ незаметного взлома Android-устройств и заражения их вредоносным ПО с помощью переданных по Wi-Fi вредоносных пакетов.

Бауэр обнаружил несколько программных ошибок в Wi-Fi драйвере qcacld, поддерживающем чипсеты Qualcomm Atheros. Данные чипсеты вместе с проблемным драйвером используются во многих Android-смартфонах, планшетах, маршрутизаторах и других устройствах, включая Pixel и Nexus 5. Всего разработчик обнаружил шесть ранее неизвестных уязвимостей, позволяющих удаленно выполнить код, и сообщил о них Google. В понедельник, 6 ноября, компания выпустила для них исправление.

Как пояснил Бауэр, Qualcomm использует SoftMAC, а значит, объект управления уровнем MAC (Media Access Control Sublayer Management Entity, MLME) обрабатывается программным, а не аппаратным обеспечением или прошивкой SoC. В связи с этим исходный код, ответственный за фреймы управления 802.11, должен быть в драйвере и поэтому виден всем. Другими словами, злоумышленник может проанализировать код и определить нужные фреймы управления. Далее он может отправить фреймы на устройство находящейся неподалеку жертвы и проэксплуатировать уязвимость.

Драйвер qcacld содержит 691 тыс. строк кода. Среди обнаруженных разработчиком уязвимостей самой серьезной является CVE-2017-11013. Проблема затрагивает файл dotllf.c и позволяет вызвать переполнение буфера, а затем удаленно выполнить код.

Источник: securitylab.ru




Добавить комментарий

Войти с помощью: